NN3.0+ or MSIE4.0+ is is required for the player to work...

 
 
Based on ERA-interim data, obtained from ECMWF through NCAR.
 
For a standard loop, click on the "repeat" and "forward"buttons.
 
Special thanks to Martin Holecko for his work with jsImagePlayer.